Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help - Will not start after some body work
08-23-2019, 17:41 (This post was last modified: 08-23-2019 19:09 by Urnie-Medie.)
Post: #1
Help - Will not start after some body work
I need some advice.
I just had some body work done on my coach - 2001LXI
Part of the work was to install a driver's side camera.
I went to pick it up today and they said it ran for about 5 minutes and shut down and they were not able to get it started. They asked me to come and see if I could help. I went and checked the things that gave me problem in the past: A/T switch - etc.
I than started the generator and it started and ran for a few minutes and shut down. I believe that there must be a cut off on the fuel line - is that correct?
Below are some of the things I noticed that should help someone with more knowledge give me some guidance.
I first want to say that while running the cables for the driver's side camera they took the connector (picture helps to show) apart and said there was a lot of corrosion - but it did run for a few minutes before shutting down. This is the door below the driver's side window.
Here are some things I noticed:
1- transmission shifting lights were not lit.
2- Warning - do not shift light was lit
3- The alarm over the dining table was giving short bursts - I did shut off the LP Master - I installed a new refrigerator and this is not needed unless I install a gas grill. This seemed to silence the alarm

I have an important trip planned next week and would like to be able to use the coach.

Not sure if I can give my phone but will try 6305615745


Attached File(s) Thumbnail(s)
─░mage

Urnie & Medie Krueger
Yorkville, IL

2001 LXi One Slide
1983 FC35 sold
Find all posts by this user
Like Post Quote this message in a reply
08-24-2019, 01:08
Post: #2
RE: Help - Will not start after some body work
That is a bit more than body work. That connector is rather complicated. I have seen folks take those connectors apart and bend pins when trying to put them back together. Seeing it runs at all I am leaning towards corrosion. That too will eat pins and once disturbed they can break off short.

I would take it apart and look at both half's under a bright light. Maybe a magnifying glass. Have a can of WD 40 or better yet some sort of contact cleaner from boat store. Shame Radio Shack is gone. Look on the back of each connector for any wire that might have broken off and pulled out of the hole. I can't say what the connector is running, but you say it is the only one they took apart. It could be some place totally different, but I am not there and they don't seem to know what they are doing. Asking you for help?
Good luck
Chris Rasmussen
2003 40Lx.
Find all posts by this user
Like Post Quote this message in a reply
[+] 1 user Likes neontwister's post
09-09-2019, 14:22
Post: #3
RE: Help - Will not start after some body work
Hi - I just wanted to give a little update on my coach.
1- The "canon" plug as quite corroded and they wired around the plug. Still nothing.
2- I contacted Allison transmission and they were very helpful. Send me the wiring for just their unit.
3- The shop where the body work was done is a GMC Heavy Truck Dealer. They had their guy check the wiring and determined that the problem was with the ECU unit. They took one off another unit there and put it on my coach and it started. I was also able to get the generator going. Everyone I talked with said the problem should not have caused any issues with the generator - but apparently it did. Possibly the corroded "canon" plug added to the generator problem.
4- It will take a few days to get the ECU. It has to come from Allison and they have to do some programing and than the dealer has to do some programing.
5- The estimated cost is $4,000 - I don't have much of a choice - just want to get the coach back.

Thanks to everyone that gave me suggestions.

Urnie

Urnie & Medie Krueger
Yorkville, IL

2001 LXi One Slide
1983 FC35 sold
Find all posts by this user
Like Post Quote this message in a reply
09-12-2019, 11:32
Post: #4
RE: Help - Will not start after some body work
Sorry to hear. I do know the Allison ECU has to 'tell' the engine ECU 'all's well' before it will start. I also have heard that if the transmission display starts wigging out and or the transmission starts acting up, DON'T turn off the engine till your in a safe place. It seems that if the Allison ECU goes south while the engine is running, the engine will continue to run since at last start up it got the all clear from the transmission. One day I will print out the entire schematic for my coach and put it on the shop wall. I bet it will be a full 4/8 board. I used to work in a factory in the machine support department. We had the whole facility in 5 different views up on each wall of the office. Plumbing, electrical, hydraulic, pneumatic and vacuum. Each was a as big as a wall ( we kept one rolled up). I bet we did the same with our coaches, after a while things would be a lot easier to understand. I am currently building a bird house. If I am lucky, I am just starting a 10+ year tenure as a Wanderlodge owner. I hope to make it a better coach in my time and keep it alive for the next generation (when they get old like me lol).
Find all posts by this user
Like Post Quote this message in a reply
[+] 1 user Likes neontwister's post
Post Reply 




User(s) browsing this thread: 1 Guest(s)